Wake on Lan (WOL)

Your bios must have WOL and possibly PME enabled!

Check wake on lan is supported by your card:
sudo ethtool eth0

You will probably see: “Wake-on: d”
This means WOL is disabled.

Create the following script: /etc/init.d/wol
#!/bin/sh
ethtool -s eth3 wol g

Then make it executable and have it begin at startup:
chmod +x /etc/init.d/wol
update-rc.d wol defaults 98

For Ubuntu users, modify the halt script in /etc/init.d/
Remove the -i on the line like this:
halt -d -f -i $poweroff $hddown

Now when you shutdown or startup, wake on lan is enabled for your card.
You can use the program 'wakeonlan' to test this

Get low cost holiday inspiration with my new project: GoHere.holiday :)