Keyboard layout lost after reboot

 

If you find that XFCE / Ubuntu is losing your keyboard setup, add the following to /etc/X11/xorg.conf under the keyboard section, ie. Section “InputDevice”

Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "gb"