Apt-cache limit of 16777216 bytes

I found this problem in Debian Etch  

As you have probably read, you need to increase the APT::Cache-Limit.

You may have already tried: apt-config dump
and had no real luck, like me!

What you need to do is either:
a) search in /etc/apt/apt.conf.d/
for a file that contains the APT::Cache-Limit parameter

or

b) create a file such as:
/etc/apt/apt.conf.d/11cache
And add the line:
APT::Cache-Limit "32768000";

I found the setting in: 70debconf